CoreJoomla software runs fine on any webserver with minimum system resources. All it require the following software installed.

  1. Joomla 1.5.15 or above, Joomla 2.5 is recommended. Joomla 1.5 versions are no longer maintained/supported
  2. PHP 5.2.0 or above (As it uses JSON requests for Ajax) or PHP 5.x with JSON PECL extension (http://pecl.php.net/package/json)
  3. MySQL 5
  4. CjLib Component