Hi.

I have been trying to install this extension and the dependency today in Joomla 3.5.1.

I initially installed by using the Upload Package File method, which failed, producing this error:-

Fatal error: Class 'CjLibLoader' not found in /htdocs/components/com_cjlib/framework.php on line 14

So after being unable to remove the extension due to not being able to access Extensions>Manage>Manage due to the above error, I manually disabled all of these extensions and attempted to install via uploading to the /tmp/ directory. Again, everything appears to install Ok, then I run into this error again.

It seems this comes from /libraries/cjlib/loader.php - which looks OK.

Reset database, removed files, try again...

I then decided to do something insane - applied 777 permissions to absolutely everything, in the hope it would install. I tried using the upload package method as well as installing from /tmp/ directory. Nope, same damn error. 

I then reset my database (for the zillionth time today...) and unzipped each package and installed each package, one at a time. Everything went well....you guessed it, same error comes back.

I see nothing wrong with the loader.php declaration of this class.

The error displays sitewide on the frontend, and also in Components > CjLib API and Community Surveys, as well as from the Manage menu.

The Joomla admin shows both CjLib API and CjLib Library are installed and enabled.

 

Any ideas? Unfortunately this is an offline server therefore cannot be accessed remotely.

Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
You do not have permissions to reply to this topic.

Powered by CjForum

Trending Topics

Athor and category hide
  • 1 reply
Hello, I am new to Community Polls. I already come that far to...

Several issues identified in the Groups Create/Edit
  • 14 replies
Hi, Today I logged into my Sociable front end, clicked on Groups...

community polls - no vote possible
  • 2 replies
Dear all, I face a problem with polls. If I create a poll e.g. with...

500 error when trying to create a poll in Community Polls
  • 5 replies
I just installed Community Polls and cannot even create a poll. I...

Sending email to people who have subscribed to a topic
  • 15 replies
If a user has subscribed to a category, then they are supposed to...