A few issues I'm running into

Category: CjForum 4 months ago
Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: A few issues I'm running into

    by » 4 months ago


    Probably I did not explain it correctly. 

    1. The observers access level has only Observers and Reinforcements groups as allowed, see attachment 1

    2. Observers and reinforcements groups are the child groups of Author, see attachment 2

    So the registered and author groups are not allowed to access the content as per the design of Joomla permission system.

    Presently there is no option to disable thankyou button, I will add it in next release. If you want to remove it manually, edit components/com_cjforum/layouts/YOURLAYOUT/topic/reply.php and remove lines from 280 to 294

    <?php if(!$user->guest && $user->id != $reply->created_by):?>
    <div class="btn-group">
    	<?php if ($isaidthankyou):?>
    	<a class="btn btn-mini btn-xs btn-success" href="#" title="<?php echo JText::_('COM_CJFORUM_TOPIC_ACTION_REMOVE_THANKYOU');?>" data-toggle="tooltip"
    		onclick="<?php echo ($found === false || $found == 2) ? 'document.adminForm.cid.value='.$reply->id.';Joomla.submitbutton(\'reply.nothankyou\'); ' : '';?>return false;">
    		<?php echo JText::_('COM_CJFORUM_TOPIC_ACTION_THANKYOU');?>
    	</a>
    	<?php else:?>
    	<a class="btn btn-mini btn-xs btn-default" href="#" title="<?php echo JText::_('COM_CJFORUM_TOPIC_ACTION_THANKYOU');?>" data-toggle="tooltip"
    		onclick="<?php echo ($found === false || $found == 2) ? 'document.adminForm.cid.value='.$reply->id.';Joomla.submitbutton(\'reply.thankyou\'); ' : '';?>return false;">
    		<?php echo JText::_('COM_CJFORUM_TOPIC_ACTION_THANKYOU');?>
    	</a>
    	<?php endif;?>
    </div>
    <?php endif;?>
    32488_2_observers_access_levels.JPG (You do not have access to download this file.)
    32488_2_observers_user_groups.JPG (You do not have access to download this file.)

    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: A few issues I'm running into

    by » 4 months ago


    Thanks, but this still doesn't make sense to me. I'm testing the site as an observer and that's when I get the problems. Registered and Author groups are not being used so their permissions aren't an issue. Observers and Reinforcements are the groups that use the forum and observers are the ones where I start to see errors. Also, the issue with wrong template and URL on new topic forms is still unaddressed. 


  • Re: A few issues I'm running into

    by » 4 months ago


    That looks weird. It looks to be some other problem then.

    Could you please create the user profile menu item in any of your menus and check? Also, can you please send me the user details with which you face the issue?


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: A few issues I'm running into

    by » 4 months ago


    There already is a user profile menu item as well as a menu for posting new topics. Please, I need this to be working. I've had to wait 24 hrs for each response and none have addressed the problem. This has been a serious setback on my end. 


  • Re: A few issues I'm running into

    by » 4 months ago


    What user details do you want me to send you? It's any user in the Observers user group. You have admin access so grab anything you need.


  • Re: A few issues I'm running into

    by » 4 months ago


    Apologies for any delay.

    I am not sure what is the issue but the username "test" is always returned "not found". I changed the profile name to "testuser" and it works. All other user profiles also working fine. I cannot find what is restricting the URL name "test" on your site.

    I fixed the issue with the topic form template selection.

    I changed the passwords of test users to debug the issue, please change them. 


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: A few issues I'm running into

    by » 4 months ago


    Thank you. 


  • Re: A few issues I'm running into

    by » 4 months ago


    I'm still having difficulties with activities. I've only published New Topic, Reply, and Comments as activities, but in the front-end, every time someone likes something it shows up on the activities page. 


  • Re: A few issues I'm running into

    by » 4 months ago


    I'm also wondering about the email notifications that get sent out. How do I edit the "from" email address for these? 


  • Re: A few issues I'm running into

    by » 4 months ago


    There is a bug with activity status. The status is not checked and hence all activities are posted. Edit components/com_cjforum/lib/stream.php and change below code

    ->where('activity_name = '.$db->q($stream->type));

    to

    ->where('activity_name = '.$db->q($stream->type))->where('published = 1');

    Emails are sent using your Joomla email settings in Global Configuration.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


You do not have permissions to reply to this topic.

Powered by CjForum