hello maverick,

i'm running into a wierd problem.

i'm builting a complicated module for m homepage, in the sence that it pulls other module inside.

on one section of this module i'm pulling both the "community answers form" module and the "community answers" module (tabs).

for some reason - the form module doesn't show in Firefox or Edge.

please see an attached screenshot of the module from Chrome. 

this is the page: www.lashonimi.co.il

i have a few other instances of the CA form module on my site and they are all showing without a problem.

the only difference between them and this one (who doesn't show) is that all the other module are assigned to a position, but this module is pulled with a shortcode.

a same shortcode is pulling the tabs CA tabs module, and it's working well. so i'm not sure what might be the problem here....

have you ever seen this before? do you have any suggestions how to solve this?

thank you very much

17174_1_form.png (You do not have access to download this file.)

online projects & marketing manager. Israel.

Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: [solved] QA form module show only on chorme

    by » 4 months ago


    Try this. Publish your form module in a custom position of your choice, let's say "my_form_module". Assign this module to all menu items. Now use loadmoduleposition short code to display it.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


  • Re: [solved] QA form module show only on chorme

    by » 4 months ago


    thank you for the fast response.

    another wierd thing - when i came to check it now, it was gone also from Chrome... i though it's a caching issue, but i cleared all cach again and againg - didn't help.

    i tried your suggestion - added a custom position and assigned to the menu items - but that didn't help niether.

    now i deleted the custom positions and all assignments - the module configurations are axactly like the CA Tabs Module below it, which is showing correctly.

    please note that i don't use the core joomla "load module" plugin - but the "modules anywhere" plugin by regular labs.

    but the same code works on all other modules in that area, including both CA and CQ modules - only this module is not loading on the page.

    any other suggestions?

    thank you 


    online projects & marketing manager. Israel.


  • Re: [solved] QA form module show only on chorme

    by » 4 months ago


    I found where the issue is. The module has only default layout but you might be using bootstrap3 or bootstrap4 layouts. So do this change. Edit modules/mod_caform/mod_caform.php and find

    require(JModuleHelper::getLayoutPath('mod_caform', $params->get('ui_layout', 'default')));

    change it to

    require(JModuleHelper::getLayoutPath('mod_caform'));

    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


    Thank you said by: yorai85

  • Re: [solved] QA form module show only on chorme

    by » 4 months ago


    hello, i'm sorry - it's a stupid mistake on my side.

    it seems the module's access level was set to "register" - i must have clicked it by mistake... when i first saw it on chrome i must have been logged in as an admin.

    sorry for creating this confusion - i will mark this thread as solved.

    thank you very much for the help anyway.

     


    online projects & marketing manager. Israel.


You do not have permissions to reply to this topic.

Powered by CjForum

Site Search

Trending Topics

26/5000 choose only 3 among several
  • 1 reply
Hello, I need a question in which you can choose only 3 options,...

Link to Post in Email now working
  • 1 reply
What version you are using?

Social User Points
  • 1 reply
Hi I did a search and didn't come up with anything but Jomsocial...

Unregistered Users
  • 1 reply
Hi. My Answer forum is completely guest user (unregistered) driven....

best answer
  • 3 replies
Hi I would like to make the best answer more prominent, such as...

Subscribe Newsletter