hello maverick,

i'm using the "Sliders" plugin by Regular Labs (see here: https://www.regularlabs.com/extensions/sliders) to add content sliders in the description for some of my quizzes & questions inside some of my quizzes.

for example see the first question on this page: https://www.lashonimi.co.il/quiz/morphology/gufim-zmanim/8-guf-zman-binyan

click the yellow button to start the quiz and then the "+" sign to open the slider - also see attached screenshots of the slider in open & closed states.

when loading the quiz's answers - the plugin is not working - it only loads the raw tags used to generate it. see 3rd screenshot attached.

is there anyway to solve this? 

should i contact the plugin's developer to solve it? and if so, do you have any idea what i need to tell them?

i'm not a developer myself so i'm not sure where this issue is coming from.

thank you very much

yorai

16992_1_slider-closed.PNG (You do not have access to download this file.)
16992_1_slider-open.PNG (You do not have access to download this file.)
16992_1_slider-raw-tags.PNG (You do not have access to download this file.)

online projects & marketing manager. Israel.

Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: "content plugins" not loading with the response layout

    by » 10 months ago


    Community Quiz will fire content plugins with the below code

    $app->triggerEvent('onContentPrepare', array('com_communityquiz.quiz',	&$item,	&$this->params,	$offset));

    So if your plugin is written to work only with the articles (i.e. the first parameter above is com_content.article), it will not work. This is applicable for quiz description.

    You said it is not working for answers, did you mean question description? For questions, context parameter is little different.

    $app->triggerEvent('onContentPrepare', array('com_communityquiz.question', &$item, &$params, 0));

    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


You do not have permissions to reply to this topic.

Powered by CjForum

Site Search

Trending Topics

kml file not working in demo site
  • 3 replies
Hi,I uploaded one kml file to your demo site...

Change date format and where are the charts?
  • 1 reply
Hi,how do I change the date format from yyyy-mm-dd to dd-mm-yyyy? I...

User name displayed twice ?
  • 1 reply
Hi,I noticed that the used name is displayed twice:Once on the...

how put a banner in community answere?
  • 1 reply
how put a banner in community answere?  

Edit the content of Email Notification
  • 1 reply
where to edit the content of Email Notification? Thanks.

Subscribe Newsletter