Hello,
I'm running Joomla 3.9.19 and PHP 7.2. I in stalled pkg_cjlib_v3.0.6.zip fine.

However, when I install pkg_communitysurveys_v5.4.6 I get the following error.

Warning : constant(): Couldn't find constant JPATH_ in /home/user/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 Warning : constant(): Couldn't find constant JPATH_ in /home/user/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 Warning : constant(): Couldn't find constant JPATH_ in /home/user/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 {"success":true,"message":null,"messages":{"message":["Installation of the package was successful."]},"data":{"redirect":"\/administrator\/index.php?option=com_installer&view=install"}}

 

I tried to reinstall with PHP 7.3 and get the same error. Any suggestions?

 

- Mike

Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: Installation error - Warning : constant(): Couldn't find constant JPATH_

    by » 5 months ago


    Hello,

    So just for a test, I unzipped the package and tried to manually install each item. All installed installed correctly execpt the following items that throw errors:

    • mod_communitysurveys.zip
    • mod_surveyform.zip
    • mod_surveyresults.zip

    first one:

    Warning : constant(): Couldn't find constant JPATH_ in /home/hospijikometrix/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 {"success":true,"message":null,"messages":{"message":["Installation of the module was successful."]},"data":{"redirect":"\/administrator\/index.php?option=com_installer&view=install"}}

    Second one:

    Warning : constant(): Couldn't find constant JPATH_ in /home/hospijikometrix/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 {"success":true,"message":"The module displays consolidated report of the selected survey in a module position.","messages":{"message":["Installation of the module was successful."]},"data":{"redirect":"\/administrator\/index.php?option=com_installer&view=install"}}

    Third one:

    Warning : constant(): Couldn't find constant JPATH_ in /home/hospijikometrix/public_html/libraries/src/Installer/Adapter/ModuleAdapter.php on line 214 {"success":true,"message":"The module displays selected survey in a module position.","messages":{"message":["Installation of the module was successful."]},"data":{"redirect":"\/administrator\/index.php?option=com_installer&view=install"}}

    Any direction would be great.

    - Mike


  • Re: Installation error - Warning : constant(): Couldn't find constant JPATH_

    by » 5 months ago


    For me these messages do not looks to be generated from Community Surveys modules. There is no JPATH_ constant referred in the installation scripts of these modules. Most probably some system plugin is throwing these messages.

    But what I see the success messages, so the installation was successful. Can you check and configure the extension parameters, create menus and start creating surveys. I don't think you will see any issues, or else let me know.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: Installation error - Warning : constant(): Couldn't find constant JPATH_

    by » 5 months ago


    Hello,

    Strange. Yes, they are there. I'll try out the modules and confirm that work leter today.

    Thanks for the feedback.

     

    - Mike


You do not have permissions to reply to this topic.

Powered by CjForum

Trending Topics

Smart Search plugin for CJF?
  • 4 replies
Looking to remove the legacy Search from my joomla site...

Multiple image selections not showing in consolidated report
  • 3 replies
I have set min 3 answers and max 3 answers in a multiple image...

Strange behavior when trying to do the same survey from two sides at the same time
  • 8 replies
Hello, I'm trying to do an anonymous survey, but I found a strange...

Survey Results show when I take the same survey again
  • 5 replies
Hi, I have an issue that when I take the same survey for a second...

Registration Page
  • 1 reply
Hi,   my Config: Joomla 3.9.23, Sociable 1.1.0, Template...