Hi,

when you go to preview view the slider outputs don't show they just show a circle is this normal?

Also where do I find the css style sheet for community surveys as need to change the button (see in the following screenshot it is the Cancel one) to look the same as the rest in terms of size, font etc. Also want to change the link colours on the social share buttons (see second screenshot). 

The modal popup on the preview front end doesn't open on top, some of it is cut off behind my main menu and I cannot close it unless I click on the back button, how do I force it to appear on top of all other layers? I can't use the page scroll either when the modal popup is open as the screen is frozen until I close the modal popup.

Kind regards

 

Mel

 

 

17585_1_button.jpg (You do not have access to download this file.)
17585_1_social.jpg (You do not have access to download this file.)
Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    Sliders: Which version of the component you are using?

    CSS: There is no specific CSS defined by community surveys. The CSS is inherited from your template bootstrap CSS library. You can switch to the corresponding bootstrap version from Community Survey options. Go to Components -> Community Surveys -> Click on the Options button on the toolbar and customize the default layout option in the integration tab. Select the right bootstrap version that your template is loading.

    Modal: I guess you are creating the survey and viewing the preview from the frontend. If that is the case, this may be a conflict with your template CSS. I am not sure if I can solve the problem but I will check it, please send me your website details via the contact us form.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    Hi Maverick I have sent you details as requested.


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    It does a couple more strange things on front end. For example if I click on the field dropdowns and try to scroll down the list of options the box jumps to the left and the last items in the list are inaccessible. 

    Are these all styling issues that can be resolved?

    What is the css for community surveys?

    I haven't fixed the modal issue unfortunately.


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    The only css used by Community Surveys is at media/com_communitysurveys/css/cj.surveys.min.css

    It will try to use your template bootstrap styles by default unless you load bundled css library via the component option (this is recommended for templates which are not based on bootstrap but for others this option should always disabled).


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    As I see the button styles are added by your template css file

    /templates/jsn_realtor/css/core/general_44f683a84163b3523afe57c2e008bc8c.css

    .btn-default {
      background: #f54c85;
      font-size: 16px;
      color: #fff;
      letter-spacing: 0px;
      -webkit-box-shadow: 0px 0px 0px 0px #d74476;
      box-shadow: 0px 0px 0px 0px #d74476;
    }

    The modal seems to be customed version of your template or bootstrap modal css itself is not provided by your template. So I think it needs heavy css fixes to fix the modal.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    Hi Maverick,

    thanks for this. I am nearly there. There are a couple of things still not working. If you prefer me to create a new thread let me know.

     

    1. The modal popup now displays properly but there is no visible way of closing/quitting it other than doing a page refresh.

    2. Although Google maps is set up correctly, with billing etc. and can be selected without problem in the field, and is set to Show in report on the field itself, the location data doesn't display in the reports.

    3. The dropdown fields in the front end view behave oddly. If I click on for example the Special Field dropdown and begin to scroll down it switches to the left and hides behind my main menu so the top couple of fields are no longer visible/selectable. 

    4. Slider does not show on front end edit questions preview - just a circle

     

    How do I fix those 4 things?

     

    Kind regards

     

    Mel


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    The preview window do not load all scripts because they will conflict with the actual form, so few question types such as sliders do not show on preview, however, you can view them properly in the actual survey. To test your survey use the following method:

    1. Set your survey to private so that it will not be published on front-end

    2. Publish the survey to start accessing it

    3. Get the unique survey URL from your survey invite page to live preview your survey

    4. When you are ready, you can edit and change the private to the public or you can continue with it.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


  • Re: Slider outputs don't show in Preview

    by » 5 weeks ago


    Hi Maverick,

    thanks, I just needed to understand how it works to explain to users.

     

    Makes sense


  • Re: Slider outputs don't show in Preview

    by » 4 weeks ago


    Hi Maverick,

     

    any solution for issues 1-3?

    Kind regards

     

    Mel


  • Re: Slider outputs don't show in Preview

    by » 4 weeks ago


    1. Can you pls upgrade v5.4.7 and check if it fixes the issue?

    2. I cannot reproduce this issue, I can see the map locations on the backend consolidated report.

    3. Can you let me know where can I see this issue? 


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    Sociable | Surveys | 
    CjForum | Polls | Answers | Quizzes | Quotes | GPS ToolsCjFit | CjBlog


You do not have permissions to reply to this topic.

Powered by CjForum

Trending Topics

Users vote for their questions and answers
  • 5 replies
Good afternoon! Users vote for their questions and answers and earn...

There is no altauserpoints profile selection
  • 1 reply
Good afternoon! There is no altauserpoints profile selection. You...

There is no limit on the number of characters
  • 6 replies
Good afternoon! There is no limit on the number of characters. You...

Unable to add ot edit photo
  • 8 replies
Hi, Unable to add or edit photo in CJForum profile. The folder open...

Multiple answers to one question
  • 2 replies
Good afternoon! It seems to me that you need to hide the response...