Article Thumbnail 'issues'

Category: Modules & Plugins 5 years ago
Hi,

just noticed that when viewing an article that has an image, a thumbnail is created id_thumb.png.
this thumbnail is used in several views.

When editing the article and deleting the image in the article, the id_thumb.png is not deleted and therefore keeps getting displayed in the views.

this is not correct: it should display the default thumbnail-small/big.png

Also: when the thumbnail is created and the image in the article is changed, the thumbnail does not get recreated to reflect the new article image. This is also not correct.

hope this helps!
regards,
Ruud.

Sharing = Caring ㋛

Like it on Facebook, +1 on Google, Tweet it or share this topic on other bookmarking websites.
  • Re: Article Thumbnail 'issues'

    by » 5 years ago


    You are correct, the thumbnail is not regenerated when you change it article. It should delete the existing one whenever the article is modified. Will do that in next release.

    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


  • Re: Article Thumbnail 'issues'

    by » 5 years ago


    Hi,
    When is the thumbnail generated? I often create new article from backend, the thumbnail is then not created but on first display of the article. Is this correct?
    Is there a way to quickly recreate the thumbnails? I often create an article for a blogger who then decides if the blog and image is okay, often they change image for the article.

    I could empty the thumnails directory, but the I have to open all articles to recreate the thumbnails or is there a 'smarter' way to do this?
    regards,
    Ruud.

    Sharing = Caring ㋛


  • Re: Article Thumbnail 'issues'

    by » 5 years ago


    It is created on first display (kind of lazy loading feature). You can quickly create by writing a content plugin which will invoke everytime the article is saved.

    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


    Thank you said by: ruud

  • Re: Article Thumbnail 'issues'

    by » 5 years ago


    Just found a 'non-developer' work-around to recreate all thumbnails:)
    remove all thumbnails in the ./media/com_cjblog/thumbnails directory and goto the following website:
    http://www.brokenlinkcheck.com and input your website url

    This tool will open all links (and by doing that all articles) and regenerate the thumbs

    As a bonus you will also get an overview of links that are not working on your website :)

    hope this helps :)

    Sharing = Caring ㋛


You do not have permissions to reply to this topic.

Powered by CjForum

Site Search

Trending Topics

Email to survey taker
  • 3 days ago.
  • 2 replies
How do I send email message to the user who takes the survey?

Conditional Rule for Text Box
  • 4 days ago.
  • 1 reply
I would like to show another text-box question if the user answers a...

Call to undefined method CJFunctions::load_component_language()
  • 4 days ago.
  • 1 reply
Hi, I was using Community surveys for a long time, but after some...

Mandatory not working for Grid Matching
  • 4 days ago.
  • 1 reply
I have a set of survey which include a question using Grid -...

Conditional Rule - Jump to page 2
  • 5 days ago.
  • 2 replies
I set a rule to say when Ship is selected it should jump to page...

Subscribe Newsletter