Lotus App Issues

Category: Lotus 2 years ago

I successfully created an .apk file using the "Build"

I successfully signed and installed it on a Galaxy Smartphone.

The following issues exist and there is nothing within my means that could correct them:

1.  Although I can upload a text "Article" with the app, I can NOT upload an image. The app indicates "Please wait while your data is uploaded!"  but it never uploads.  Once again, I can upload text messages, I just can't upload the "Intro Image."

2.  I cannot "Submit" the "Contact Us" message, the Submit link does not work.

3. No "Notifications" work at all.

I rebuilt the app several times but I always get the exact same issue listed above.  There is nothing I can possibly do at my end. All information has been entered correctly and the app functions except for the above issues at this time.

Like it on Facebook, Tweet it or share this topic on other bookmarking websites.
  • Re: Lotus App Issues

    by » 2 years ago


    I am looking into these issues and will provide you the update soon.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


  • Re: Lotus App Issues

    by » 2 years ago


    Maverick:

     

    I figured out the problem with uploading images in Articles.  I had to give my Galaxy Smartphone the permissions to allow for the upload so that problem is not with the app. Its working now.

    But, I still can't send the Contact Us email and I do not get notifications of any kind. They are not in the CJlib component either, if that is what is supposed to happen.

    Also, is there are way to upload images to the Article body in addition to the Intro? Is there also a way to have the uploads from the App automatically get "Published".  Right now I have to go in and activate them.  I am going to use the app with a private group so I don't need to review Article submissions before they go online.


  • Re: Lotus App Issues

    by » 2 years ago


    The messages will be sent directly using your Joomla mailer settings. I tested this with the corejoomla app and could get the mail as expected. Are you able to send emails from other extensions?

    Images within the body are not possible as the editor do not support such functionality. Mobile editors usually are very restricted.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


  • Re: Lotus App Issues

    by » 2 years ago


    I figured out why the Submit button would not work to send Contact Us mail. The "Show Captcha" in Lotus app is not functional. Whether it is set to "Hide" or "Show", it requires that Captcha be set. Although I had set to "Hide", the Submit button would not function because there was no Captcha installed.  

    Your Lotus .apk builder is a really great product for quickly creating .apk files and, for the most part, it functions fine. However, I still have some issues to resolve.

    I "Built" test apps for 3 different test sites and I get the same results on all 3 of them:

    1. The "Notifications" do not work at all on any of them. It has been tested on a few Android devices, with proper permissions set for notifications in the settings, but no results.

    2. When using the Forum and Questions extensions in the app, the keyboard of the Android devices obscures the "Save" (Send) button at the bottom of the screen. In Articles, the send button (checkmark) is in the top menu area so that works well.  A user can still send in Forum and Questions mode if they know enough to press the "Back" button on their devices but most people I know will never figure that out.

    3. As I mentioned, the Lotus captcha "hide" button does not work so Captcha appears and is required regardless of the setting or the Contact Us will not Submit. Also, users who are not signed in can still use the Contact Us link and the app appears to send their email but it does not. There is no way for the user to know that his Contact Us message was not sent because he was not signed in. There are no messages in Contact Us to let a user know if their mail was sent whether they are signed in or not.

    4. When a user creates an Article it is created "unpublished" and does not appear automatically. The Forums and Questions do not have this issus. My apps will be used on private sites. I don't need to moderate them so I don't want to have to go in and Publish them.

    5.  Is there any way for me to change the Lotus code so that the app defaults to the users Profile?  A profile default would be much better for me because the the entire menu of items Articles, Topis, Questions apprears in the menu along with their profile.


  • Re: Lotus App Issues

    by » 2 years ago


    1. Can you please let me know how you are sending notifications? You need to send notifications from your firebase console. Direct firebase integration from your website to app is not available at present, but we are working on it.

    2. I too noticed this, will move the save button on to the toolbar position in next release.

    3. This looks to be bug. Will check and fix it. It should send the message irrespective of user logged in or not.

    4. By default Joomla article status is unpublished when publishing from front-end (hence your article is unpublished by default). I am adding a workaround for it as a configurable option to automatically publish the article.

    5. I can provide you the source code if you can modify. Otherwise, will add this option with next release.


    Follow me on twitter: https://twitter.com/corejoomla
    If you use our extensions, please post a rating and a review at the Joomla! Extensions Directory.
    CjFitCjForum | Polls | Answers | Quizzes | Quotes | Surveys | GPS Tools | CjBlog


  • Re: Lotus App Issues

    by » 2 years ago


    Maverick:

    Thank you very much for addressing each of the issues I noted above re the Lotus extension and app. 

    I will continue trying to get the Notifications to work if you think that issue is at my end.

    Yes, when you have time, it would be great if you could send me the source code to modify the app so that it would default to the User's Profile rather than the Articles, Forum, or Answers.

    Thank again for the professional support.

    Zebra2


You do not have permissions to reply to this topic.

Powered by CjForum

Site Search

Subscribe Newsletter